Konsep dan Setting Load Balance MikroTik

Load Balance MikroTik umumnya diterapkan ketika kita mempunyai 2 link network atau lebih, bertujuan untuk membagi beban traffic data melalui 2 link atau lebih dan disebarkan secara seimbang atau rata.

Konfigurasi Load Balance pada MikroTik

Artikel kali ini DSI akan berbagi Tutorial load balance MikroTik menggunakan metode PCC dengan 2 line ISP.

Apa itu PCC? tentunya setelah anda melihat video di atas maka anda sudah pasti tau jawabannya.

Anggap saja sebagai contoh kita menggunakan ‘ISP A’ dan ‘ISP B’,  2 ISP tersebut saya hubungkan pada mikrotik ether3 dan ether4, anda bebas mau di hubungkan pada ether berapa yang terpenting conected.

Sebelum anda mulai pastikan MikroTik anda sudah di konfigurasi sebagai router, karena disini DSI hanya menjelaskan mengenai Konfigurasi Load Balance dengan metode PCC saja.

Load Balance MikroTik - Topology Image

Langkah – Langkah Nya :

  • Buka winbox kemudian login
  • Copy script di bawah ini kemudian paste ke dalam text editor seperti notepad++, edit nama interface dan sesuaikan dengan kondisi pada mikrotik anda lalu copy script yang sudah di edit kemudian masukan ke “new terminal” winbox
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Pulang Pergi Lewat ISP yang sama" connection-mark=no-mark in-interface=ether3-wanA new-connection-mark=conn-WanA
    add action=mark-routing chain=output connection-mark=conn-WanA new-routing-mark=lewat-ISP-A
    add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether4-wanB new-connection-mark=conn-WanB
    add action=mark-routing chain=output connection-mark=conn-WanB new-routing-mark=lewat-ISP-B
    

    Fungsi script di atas adalah agar paket yang sudah melewati ISP A maka pulang pergi harus melewati ISP A, begitu juga dengan paket yang melewati ISP B.

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Per Connection Load Balance" dst-port=80,8080 in-interface=ether2-Lan new-connection-mark=conn-LanA per-connection-classifier=src-address-and-port:2/0 protocol=tcp src-address=192.168.2.0/24
    add action=mark-routing chain=prerouting connection-mark=conn-LanA in-interface=ether2-Lan new-routing-mark=lewat-ISP-A passthrough=no
    add action=mark-connection chain=prerouting dst-port=80,8080 in-interface=ether2-Lan new-connection-mark=conn-LanB per-connection-classifier=src-address-and-port:2/1 protocol=tcp src-address=192.168.2.0/24
    add action=mark-routing chain=prerouting connection-mark=conn-LanB in-interface=ether2-Lan new-routing-mark=lewat-ISP-B passthrough=no
    add action=mark-connection chain=prerouting comment="Per Address Load Balance" in-interface=ether2-Lan new-connection-mark=conn-LanA per-connection-classifier=both-addresses:2/0 src-address=192.168.2.0/24
    add action=mark-routing chain=prerouting connection-mark=conn-LanA in-interface=ether2-Lan new-routing-mark=lewat-ISP-A passthrough=no
    add action=mark-connection chain=prerouting in-interface=ether2-Lan new-connection-mark=conn-LanB per-connection-classifier=both-addresses:2/1 src-address=192.168.2.0/24
    add action=mark-routing chain=prerouting connection-mark=conn-LanB in-interface=ether2-Lan new-routing-mark=lewat-ISP-B passthrough=no
    

    Fungsi Script di atas adalah, menandai koneksi yang sudah di tentukan berdasarkan classifier dan membuat routing mark berdasarkan koneksi yang sudah di buat.

    /ip route
    add distance=1 gateway=192.168.86.1 routing-mark=lewat-ISP-A
    add distance=2 gateway=192.168.137.1 routing-mark=lewat-ISP-B
    

    Fungsi Script di atas untuk memasukkan default route berdasarkan routing mark yang sudah di tentukan.

  • Sampai disini kita sudah selesai untuk setting load balance dengan 2 ISP

Keterangan:

  • ether2-Lan adalah interface yang terhubung ke lokal
  • ether3-wanA adalah interface yang terhubung ISP A
  • ether4-wanB adalah interface yang terhubung ISP B
  • 192.168.2.0/24 adalah IP lokal
  • 192.168.86.1 adalah gateway ISP A
  • 192.168.137.1 adalah gateway ISP B

Load Balance MikroTik - image2

Berikut contoh hasil dari speed test:
Load Balance MikroTik - image3

Jika anda masih belum berhasil silahkan di ulang dan coba lakukan lebih teliti lagi. Script di atas adalah hanya basic, jika anda sudah paham konsep nya maka metode yang di terapkan bisa lebih spesifik.

Semoga tutorial setting load balance mikrotik dengan metode pcc, dapat bermanfaat buat pembaca semuanya. Jangan lupa tinggalkan komentar di bawah ini jika anda mempunyai masalah seputar artikel di atas. Mohon kritik dan saran jika DSI salah dalam memberikan info atau script.

Terimakasih atas kunjungannya. Salam sejahtera selalu untuk yang membaca..

10 Comments

Silahkan tinggalkan komentar: