Setting VPN dengan mode PPTP di MikroTik

Membangun VPN dengan MikroTik Router sebagai Server dan Client.  PPTP (Point to Point Tunnel Protocol) termasuk mode yang dapat digunakan untuk membangun sebuah jaringan Virtual Private Network (VPN).

Syarat utama agar terbentuknya VPN kita harus memakai protokol tunnel yang sudah di support oleh device yang akan kita gunakan.

Pada Mikrotik bisa kita fungsikan sebagai PPTP baik sebagai Server ataupun Client.

Untuk menjadi PPTP server baik secara lokal atau Publik harus bisa di hubungi dari sisi Client. Maksudnya adalah IP PPTP server harus bisa di ping dari sisi client, seperti itu kira-kira gambaran mudahnya.

Masih bingung?…

sama gan, saya juga baru belajar soal VPN, jadi harap maklum kalau penjelasan saya ini aneh.

Baiklah itulah sedikit ulasan dari DSI mengenai VPN yang akan kita konfigurasi pada Mikrotik.

PPTP SERVER

Berikut cara setting pptp server pada Mikrotik lewat WINBOX

  • Lewat Terminal Winbox :

Aktifkan PPTP Server

/interface pptp-server server set enabled=yes

Bikin pool untuk alokasi IP ke ppt p-client secara dinamis

/ip pool
add name=ppp-pool ranges=10.10.0.20-10.10.10.2

range IP di atas hanyalah contoh, silahkan ada ganti sesuai kebutuhan

Bikin Profile

/ppp profile
add local-address=10.10.10.1 name=contoh-profile remote-address=ppp-pool use-encryption=required

Bikin user untuk login pada PPTP-Client

/ppp secret
add name=DSI password=123 profile=contoh-profil
  • Lewat Menu tool pada winbox

pptp-server

pptp-server

pptp-server

Sampai di sini konfigurasi PPTP server sudah siap di gunakan.

PPTP CLIENT





Berikut cara setting PP TP-Client lewat Winbox:

Perhatian :

  • Pastikan anda sudah mendapatkan detail account VPN seperti IP, User, dan password.

Bikin Interface PPTP-Client

pptp client

Sampai di sini interface baru pptp sudah anda buat, jika status connected (terhubung) anda harus buat NAT agar bisa di pakai untuk hubungan ke pp tp server dari IP yang sejajar pada jaringan anda.

pptp client

Sampai sini vpn anda sudah siap dan bisa di pakai sesuai kebutuhan.

Permasalahan :

Masalah akan muncul pada jaringan yang mempunyai link ISP lebih dari 2, biasanya karena faktor loadbalance.

PPTP akan selalu putus dan nyambung, itu di sebabkan karena pergantian gateway.

Solusinya:

Bikin statik Routing menuju IP PP TP server dengan mimilih salah satu link.

Kalo bahasa awam nya seperti saya, kita harus pilih salah satu jalan menuju ke kota, jangan pindah-pindah.

untuk membuat statik Routing, lihat pada gambar berikut:

pptp client

Keterangan:

  • IP 43.42.41.40 adalah IP VPN Server, atau IP yang anda dapat dari penjual VPN server.
  • IP 192.168.1.1 adalah IP gateway dari salah satu link

Catatan:

jika anda menggunakan link lebih dari 2 dan ada salah satu link khusus untuk game, maka gunakan lah gateway tersebut dari IP link game.

Sampai di sini pembangunan VPN sudah selesai kita buat dengan mode PPTP. semoga dengan tutorial yang saya berikan dapat bermanfaat bagi anda pembaca semuanya.

Saya mohon maaf bila ada kata atau pun script dan cara yang salah kami dengan senang hati menerima kritik dan sarannya. Tolong diluruskan bila mana ada cara atau tahapan yang salah.

Salam Sukses selalu

 

2 Comments

Leave a Reply