Mengarahkan User Expired Hotspot ke halaman Informasi

Apakah pelanggan hotspot anda banyak yang belum bayar iuran?

Beritahu pelanggan anda bahwa paket internet yang di beli sudah habis.

Dengan trik ini anda akan di mudah kan saat ingin menagih pelanggan yang selalu telat membayar.

Menutup ( blokir ) user yang sudah expired dan mengarahkan ke halaman informasi akan memberikan kesan yang baik pada pelanggan hotspot anda. Ajak pelanggan anda untuk tetap melanjutkan paket nya dan berikan sedikit diskon atau tawaran harga yang lebih murah, dengan cara ini dapat mengurangi pelanggan yang akan pindah ke tempat lain.

Berikut cara mengarahkan (Redirect) user hotspot yang sudah expired:

1. Menambah IP Address HOTSPOT

IP address baru tersebut akan digunakan oleh user yang sudah expired.

gambarannya seperti ini..

Hotspot anda di setting pada ether4, maka anda harus menambah IP address pada ether4.

Saya contohkan menambah IP 192.168.168.1/24 pada ether4 untuk user expired.

Membuat pool dengan range sesuai subnet IP tersebut.

Lihat gambar berikut untuk lebih jelasnya.

hotspot address - pool

2. MEMBUAT HALAMAN INFO

Buatlah sebuah halaman (page) informasi berbentuk html  dan simpanlah pada folder (directory) hotspot.

Saya beri contoh halaman yang sudah saya buat bernama expired.html dan menyimpannya pada folder hotspot.

Lihat gambar berikut:

hotspot expired -1

Perhatian!

Terkadang nama folder tidak sama, biasanya setelah merubah login page hotspot. Silahkan sesuaikan dengan folder hotspot di mikrotik nada.

3. Mengaktifkan WEB PROXY MikroTik

Penggunaan Web Proxy mikrotik untuk mengarahkan (redirect) halaman yang di request oleh pelanggan menuju ke halaman informasi yang sudah di buat. Sehingga setiap user expired yang ingin buka halaman website otomatis dialihkan ke halaman informasi.

Apakah bisa menggunakan Squid Proxy?

Jawabannya tentu saja bisa. Namun di sini saya hanya menjelaskan menggunakan Web Proxy MikroTik.

hotspot - web proxy

Keterangan!

  1. Aktifkan web proxy mikrotik dengan standar port 8080.
  2. Buatlah aturan (rule) dari tab Access. Aturan ini akan berlaku jika yang melakukan request adalah IP 192.168.168.0/24 dan akan di blok (deny) lalu di alihkan ke halaman 192.168.2.1/expired.html.
  3. 192.168.2.1 adalah IP address utama hotspot.

4. Blokir IP User Expired

Membuat aturan di filter untuk melakukan blokir IP yang berasal dari 192.168.168.0/24 dan hanya di bolehkan untuk mengakses halaman expired.html



/ip firewall filter
add chain=forward comment="Allow access expired.html" dst-port=80 protocol=tcp src-address=192.168.168.0/24
add action=drop chain=forward comment="Drop Access Internet" src-address=192.168.168.0/24

5. NAT | Alihkan Browsing ke Web Proxy

/ip firewall nat
add action=redirect chain=dstnat comment=”Direct Expired user” dst-port=80 protocol=tcp src-address=192.168.168.0/24 to-ports=8080
[/code

Script di atas akan memaksa IP yang berasal dari 192.168.168.0/24 untuk menggunakan web proxy .

6. Mengarahkan User Expired ke Halaman Informasi

Sekarang saatnya untuk mengarahkan setiap user hotspot yang sudah expired ke halamanan informasi.

Caranya bisa dilakukan dengan 2 cara:

Manual Setting

buatlah user-profile dengan memasukan pool expired. Lihat gambar berikut:
hotspot - user profile

Ganti Profile Setiap User Yang sudah Expired. Lihat gambar berikut:

hotspot - user

Seperti itu kira-kira untuk mengalihkan user expired ke halaman informasi secara manual. Silahkan anda test langsung untuk melihat hasilnya.

Automatis Setting

Cara ini sedikit berbeda dengan cara yang pertama, karena cara yang kedua harus menggunakan Usermanager.

Kenapa harus menggunakan Usermanager?…

…Usermanager mendukung untuk memakai 2 profile atau lebih dalam 1 user hotspot. Ketika Profile pertama habis otomatis pindah ke profile berikutnya.

Disitulah kita memanfaatkan pergantian profile yang bisa di lakukan oleh Usermanager secara otomatis.

Buatlah profile dengan menambah pool expired. Lihat gambar berikut:

hotspot - usermanager profile

Buatlah satu user untuk uji coba, atau edit user yang sudah ada lalu tambahkan profile expired seperti gambar berikut ini:

Hotspot - User1

Contoh User diatas saya buat untuk pelanggan yang ingin paket 10MB, ketika quota sudah habis maka otomatis beralih ke profile expired.

Gimana…? mudah bukan?..

Silahkan anda coba sendiri, lakukan test ke beberapa user, dan lihat hasilnya…

Saya sudah buat video hasil uji coba mengarahkan user hotspot yang sudah expired lewat video berikut ini.

Kesimpulan!:

Ketika pelanggan hotspot anda sudah habis paket nya, maka pelanggan anda masih bisa login ke hotspot. Tetapi pada saat User ingin buka situs seperti detik.com, maka secara otomatis situs yang dibuka dialihkan ke halaman informasi yang sudah kita tentukan. Trik yang sangat sederhana tetapi dapat membantu anda meringankan kerjaan.

Demikian tutorial kali ini, semoga artikel ini dapat di mengerti dan menjadi informasi yang bermanfaat untuk anda semua.

Jangan lupa Share ke medsos dan subscribe jika artikel ini bermanfaat bagi anda dan teman-teman anda.

Jika ada pertanyaan atau permasalahan seputar artikel di atas, silahkan tinggalkan lewat komentar di bawah ini.

Terimakasih

9 Comments

Silahkan tinggalkan komentar: